PREFACE

Considering today's networked world, it is essential for any human being to understand the fundamental areas of computing. Awareness of basic knowledge of computers such as the block diagram, input and output devices, operating systems and other software etc. are mandatory to work with a computer. Apart from the knowledge of fundamentals of computer, one should also familiar with basics of documentation such as writing a letter, creating spreadsheets and presentations which is the need of the time. Network and Internet are making the world as a home; hence once should be familiar with this world of networking to connect to the outside world of information.

This reference material titled “Basic Computer Training” is designed to familiarize with the participants with fundamental of computer science and to build on their knowledge on computer basic terminologies. It also provides a platform to understand Ubuntu operating system environment and then leads overview of LibreOffice, which is an open-source office productivity tool. This reference material also helps the participants about the Network and Internet concepts and makes them aware about the basic Internet concepts such as search engines, e-mails etc. which will help them to connect to the outside world using the latest technical enhancements.
TABLE OF CONTENTS

CHAPTER 1: INTRODUCTION TO PERSONAL COMPUTERS

AN INTRODUCTION TO PERSONAL COMPUTER ................................................................. 2
  WHAT IS A COMPUTER? ............................................................................................... 2
  TYPES OF COMPUTERS ............................................................................................. 2
  MAJOR CHARACTERISTICS OF COMPUTERS .............................................................. 3

COMPUTER ORGANIZATION AND HARDWARE ......................................................... 4
  ORGANIZATION OF COMPUTER ............................................................................... 4
  SYSTEM COMPONENTS .............................................................................................. 5
  INPUT DEVICES ......................................................................................................... 10
    Other Types of Input Devices .................................................................................. 12
  OUTPUT DEVICES ...................................................................................................... 13
    Monitor ..................................................................................................................... 13
    Printers .................................................................................................................... 13
    Speakers .................................................................................................................. 14
  OTHER PERIPHERAL DEVICES .................................................................................... 14
  TIPS FOR THE MAINTENANCE OF UPS SYSTEM .................................................... 17

CHAPTER 2: INTRODUCTION TO UBUNTU OPERATING SYSTEM AND WORKING WITH INTERNET

INTRODUCTION TO OPERATING SYSTEMS .................................................................. 20

INTRODUCTION TO UBUNTU OPERATING SYSTEM .................................................... 21
  LOGIN SCREEN OF UBUNTU ...................................................................................... 21
  UNDERSTANDING THE UBUNTU DESKTOP ............................................................. 22
  THE DESKTOP BACKGROUND ................................................................................... 23
  THE LAUNCHER ......................................................................................................... 24
  THE DASH .................................................................................................................. 25
  THE WORKSPACES .................................................................................................... 26
  MANAGING WINDOWS ............................................................................................... 27
CLOSING, MAXIMIZING, RESTORING, AND MINIMIZING WINDOWS .................................................. 28
MOVING AND RESIZING WINDOWS ........................................................................................................ 29
SWITCHING BETWEEN OPEN WINDOWS .................................................................................................... 29
MOVING A WINDOW TO DIFFERENT WORKSPACE .................................................................................. 29
PLACES ...................................................................................................................................................... 30
HOME FOLDER .......................................................................................................................................... 31
NAUTILUS FILE MANAGER ...................................................................................................................... 31
OPENING FILES .......................................................................................................................................... 31
CREATING NEW FOLDERS .......................................................................................................................... 32
COPYING AND MOVING FILES AND FOLDERS ...................................................................................... 33
USING MULTIPLE TABS AND MULTIPLE NAUTILUS WINDOWS ............................................................. 34
SHUT DOWN THE SYSTEM ....................................................................................................................... 35
INTRODUCTION TO NETWORK .................................................................................................................. 36
INTRODUCTION TO INTERNET .................................................................................................................... 36
The World Wide Web (WWW) ..................................................................................................................... 37
INTRODUCTION TO EMAIL .......................................................................................................................... 40
E-MAIL VIEWS ............................................................................................................................................ 41
Read New Email .......................................................................................................................................... 41
Send Email .................................................................................................................................................. 41

CHAPTER 3: INTRODUCTION TO LIBREOFFICE WRITER

OVERVIEW OF LIBREOFFICE ...................................................................................................................... 46
WORKING WITH LIBREOFFICE WRITER ................................................................................................... 47
USING MENUS AND TOOLBARS .................................................................................................................. 47
OPENING A DOCUMENT .............................................................................................................................. 48
SAVING A DOCUMENT .................................................................................................................................. 50
SAVING AN EXISTING DOCUMENT AT DIFFERENT LOCATION ............................................................ 51
Saving Document in Other Formats ........................................................................................................... 51
PREVIEWING A DOCUMENT ....................................................................................................................... 52
CHAPTER 4: INTRODUCTION TO LIBREOFFICE CALC

OVERVIEW OF LIBREOFFICE CALC ................................................................. 74
GETTING STARTED WITH LIBREOFFICE CALC .................................................. 74
SAVE A FILE ......................................................................................................... 75
Saving a File in Other Formats .......................................................................... 76
OPENING A FILE .................................................................................................. 76
FORMATTING TEXT AND NUMBERS ................................................................. 77
SELECTING CELLS .............................................................................................. 78
FORMATTING CELLS ........................................................................................... 78
Basic Computer Training

USING TABLE AUTOFORMAT ................................................................. 79
COPYING AND PASTING CELLS ............................................................ 80
TEXT SUPERSCRIPT AND TEXT SUBSCRIPT ........................................... 81
ROTATING TEXT ..................................................................................... 82

TEXT ALIGNMENT .................................................................................. 84

CONDITIONAL FORMATTING ............................................................... 85
NAMING CELLS ....................................................................................... 85
ROUNDING-OFF NUMBERS ................................................................. 86
FORMATTING NUMBERS ....................................................................... 87
ENTERING FRACTIONS .......................................................................... 88

FORMATTING SPREADSHEETS .............................................................. 88

FORMATTING CELL BORDER AND BACKGROUND ................................ 89
ADDING, DELETING, AND RENAMING SHEETS OF A SPREADSHEET .... 91

CREATING AND MODIFYING CHARTS .................................................. 93

ANALYZING DATA ................................................................................. 95

AUTOFILTER ........................................................................................... 96
Advanced Filters .................................................................................... 96

MANAGING ROWS AND COLUMNS ....................................................... 98

INSERTING ROWS AND COLUMNS ....................................................... 98
FORMATTING ROWS AND COLUMNS ................................................... 98

FORMULAS AND CALCULATIONS ......................................................... 99

CALCULATING USING FORMULAS ..................................................... 99
CALCULATING THE SERIES AUTOMATICALLY ..................................... 100
Chapter 1: Introduction to Personal Computers

Chapter Objectives:
This chapter provides an inner view of Personal Computers and its usage in the current technical world. The chapter starts with the characteristics and then takes the reader to the overview of its hardware and software components. This chapter also helps the reader to get familiar with different Input and Output devices attached with a personal computer.

Chapter in a Nutshell:
AN INTRODUCTION TO PERSONAL COMPUTER

WHAT IS A COMPUTER?

TYPES OF COMPUTERS

MAJOR CHARACTERISTICS OF COMPUTERS

COMPUTER ORGANIZATION AND HARDWARE

ORGANIZATION OF COMPUTER SYSTEM COMPONENTS

INPUT DEVICES

Other Types of Input Devices

OUTPUT DEVICES

Monitor
Printers
Speakers

OTHER PERIPHERAL DEVICES

TIPS FOR THE MAINTENANCE OF UPS SYSTEM
An Introduction to Personal Computer

In the new era of technical world, personal computers have become an integral part of human lives. Take any example of life; most of our communication with the world around us takes place with the help of these personal computers. Personal computers are based on the microprocessor technology which works on microchip technology. We can use personal computers for word processing, accounting, desktop publishing, and spreadsheet and database management applications.

What is a Computer?

Computer can be defined as an electronic device made up of electronic and electromechanical components. The computer itself cannot perform any task and consists of majorly three elements.

- **Hardware**: The physical components which are visible physically, touch and feel in the computer system are called hardware E.g. monitor, keyboard, mouse etc.
- **Software**: Software is used to describe the instructions that instruct the computer how to perform a task. Software can be categorized as 1) System software (e.g. Operating Systems, Compilers, Editors etc.) 2) Application Software (MS Word, Excel, Accounting packages LibreOffice etc.)
- **Users**: People who operate or use the computer and also create computer software instructions.

Types of Computers

1. **Desktop**: Usually includes a tower-style system unit with an external keyboard, a monitor, and a mouse. A desktop is the most powerful of all the types of personal computers because it can be easily upgraded by adding or replacing components.
2. **Laptop**: A type of personal computer that integrates the system unit, monitor, keyboard, and mouse available with a desktop computer into one portable package with either be plugged into an electrical outlet or battery operated.
3. **Handheld**: This is the smallest type of personal computer making it easy to carry anywhere. Handhelds are battery-operated with targeted but limited capabilities. Usually, a small keyboard or a pen-like stylus is used to operate a handheld.

**Major Characteristics of Computers**

The latest technology and computers are used in nearly every facet of modern day life. They are designed for individual use and provide a wide range of functions and services applicable to varied environments such as businesses, offices, hospitals, schools, and homes. Following are the characteristics of computers:

- **Speed**: A computer is a very fast device. It can carry out instructions at a very high speed. The speed of computer is calculated in MHz that is one million instructions per second.
- **Accuracy**: Accuracy of a computer is consistently high and the degree of accuracy of a particular computer depends on the instructions and the type of processor.
- **Versatility**: Multi-processing features of computer makes it quite versatile in nature. It means that it can perform different types of tasks with same ease.
- **Reliability**: Computer provides very high speed accompanied by an equality high level for reliability. Thus computers never make mistakes of their own accord.
- **Memory**: A computer can store and recall any amount of information because of its secondary storage capability. Every piece of information can be retained as long as desired by the user and it can be recalled information almost instantaneously.
- **No Brain**: Computer does not possess any intelligence of its own. It can only perform tasks that a human being can. The difference is that it performs these tasks with speed and accuracy.
- **Diligence**: The computer is a machine, does not suffer from the human traits of tiredness. Nor does it lose concentration even after working continuously for a long time.
- **Storage**: Data storage is essential function of the computer. The computers have a lots of a storage devices such as CD/DVD/External Hard Disk Drives etc. which can store a tremendous amount of data permanently.
The latest communication and technology increased the use of computers in the areas like touching up digital photos, shopping on the Internet, buying and selling items online, voice transfer through the internet and many more such kind of advanced activities, where a normal human being cannot even think of. Some of the most common tasks computers can help the users with:

- Communicating by using chat/e-mail/voice mail etc.
- Online Banking
- Searching information using the Internet
- Budgeting and performing accounting tasks
- Analyzing numeric information
- Searching through lists or reports for specific information
- Scheduling and planning projects
- Creating illustrations / Gaming

**Computer Organization and Hardware**

Basic components in a computer system are Central Processing Unit (CPU), Memory, the Input and Output devices. CPU is said to be the brain of a computer where most calculations or processing takes place. Memory is a part of the system where the data stores temporarily or permanently. The Input and Output system of a computer system helps the user to interact with a computer.

**Organization of Computer**

A computer can majorly performs five major operations irrespective of their type. It accepts data or instructions by way of input, it stores data in the temporary storage space called “Primary Memory” such as RAM, it process data as required by the user, it produce results in the form of output or it permanently stores the information in a space called “Storage” or “Hard Disk” (“Secondary Memory”), and it controls all operations inside a computer.

All these functions are illustrated in the basic block diagram of a computer shown below:
Chapter 1: Introduction to Personal Computers

Fig. 1.1: Computer Block Diagram

System Components

The main computer system contains components like processor, memory, controllers, etc. connected together with a bus (consists of many parallel wires, usually printed (in copper) on the main circuit board (Motherboard) of the computer). Following are the major system components:

- Motherboard
- Processor
- Memory (Primary)
- Hard disk (Secondary memory)
- Power Supply
- Cabinet

Motherboard:
The motherboard is the important component of the computer where system components are connected to it. It controls all activities of the system. The image showed below depicts the components available with a normal motherboard:
**Processor (CPU):**

- The processor (CPU) is called as the brain of the computer.
- It reads the commands from the (primary) memory and then executes them as per the instructions by the control unit.
- All work that you do on your computer is performed directly or indirectly by the processor.
- Advanced Micro Devices (AMD) and Intel are two primary manufacturers of computer microprocessors.
- AMD's desktop processors include Sempron, Athlon and Phenom. Intel's desktop CPUs include Celeron, Pentium and Core.
- Intel makes Celeron M, Pentium M and Core mobile processors for notebooks. Both companies make both single-core and multi-core processors.

*Fig. 1.3: Different type of processors*

- Each processor has a clock speed which is measured in gigahertz (GHz).
A processor has a front side bus which connects it with the system’s random access memory (RAM).

Cache is a type of fast memory which serves as a buffer between RAM and the processor. The processor’s socket type determines the motherboard type where it can be installed.

**Memory (Primary):**

- Is used to hold programs and data during execution.
- This type of memory is called as primary memory because it is accessed directly by the processor for fetching data.
- Primary memory is often called as Random Access Memory.
- RAM holds all data and programs the processor is using at a given point of time.
- Contents of RAM are erased when power is switched off. This nature of RAM is volatile.
- The other type of system memory is ROM (Read only Memory) which is permanent because it contents are not erased even when power is switched off. It is usually used to load an operating system.
- The more RAM your computer has the more programs and documents you can open without slowing the system down.
- Today’s computers have RAM anywhere from 1 GB to 192 GB depending on the hardware and the operating system you are using.

*Fig. 1.4: Random Access Memory (RAM)*
Hard disk drive (Secondary memory):

- A hard drive consists of spinning platters made up of aluminum or ceramic that is coated with magnetic media.
- Hard drive is also called as Secondary Memory.
- There can be several programs in the system, which cannot be stored in RAM, so we need a very huge non-volatile memory, which can be used for storing all the programs, and data when the system is not in use are called as Hard disks.
- The capacity of the HDD is measured in GBs/TBs.

Fig. 1.5: Hard Disk Drive (HDD)

CD-ROM/DVD drive:

- CD-ROM stands for compact disk read only memory and DVD stands for Digital Versatile/Video Disc.
- It consists of small disks similar to the gramophone records to hold digital information. As the name applies they are read only medium.

Fig. 1.6: Digital Versatile Disc (DVD) Player
Note:

- Each hard disk/CD drive is identified by different letters such as C:, D: etc.
- The hard drive is always the C: drive because it is the first available drive letter for hard drives.
- The computer assigns the A: and B: drives to floppy disks and sometimes other removable media such as tape drives.
- As you install other hard drives, create new partitions, and add other drives such as CD-ROM or DVD drives, they will be assigned to other drive letters after C, such as D, E, F, G, etc.

SMPS (Switch Mode Power Supply):

- The power supply supplies power to every single part in the PC.
- The main function of the power supply is to convert the 230 V AC into 3.3 V, 5 V and 12 V DC power that the system requires for the operations.
- In addition to supplying power to run the system, the power supply also ensures that the system does not run unless the power supplied is sufficient to operate the system properly.

![SMPS Image](image_url)

*Fig. 1.7: Switch Mode Power Supply (SMPS)*

Cabinet:

- The box or outer shell that houses most of the computers is called the cabinet.
- The cabinet actually performs several important functions for your PC including protection to the system components, directing cooling airflow, and allowing installation of and access to the system components.
Chapter 1: Introduction to Personal Computers

Assam e-District Project

The cabinet often includes a matching power supply and must also be designed with the shape of the motherboard and other system components in mind.

Fig. 1.8: The Cabinet

Input Devices

If you buy any product, it required certain external accessories and energy resources to finally resume the operation. Assume that you have bought a new fridge for your home. You need to provide it with energy resource as electricity to it to function. Similarly, to use a computer effectively to create and manage your tasks, you will have to provide some basic input. The devices which gives input or information to a computer is called Input devices. There are numerous devices that you can use.

Keyboard:

- A keyboard is an input device that is made up of individual keys presented in a standard arrangement of characters representing numerals from 0 through 9, alphabet, and symbols.
- The keyboard is a medium between the user and the computer also used to manage the cursor and other related activities.
- There are different types of keys present on the keyboard such as the keys for typing, the numeric keypad, the function keys, and the control keys.
Chapter 1: Introduction to Personal Computers

Assam e-District Project

Fig. 1: Keyboard

- A small handheld input device used for moving the cursor on the computer screen.
- It has at least two buttons: a left and a right mouse button and a scroll wheel.
- There are two different types of mouse available in the market: mechanical mouse and optical mouse.
- In mechanical mouse, a ball fixed underneath the mouse rolls and comes in contact with a set of rollers inside the mouse's casing, which helps the computer to identify its movements.
- In optical mouse, rollers use digital signals to move the mouse pointer.

Fig. 1.1: Mouse

Scanners:
- A scanner can be defined as an input device that reads hard copy text, illustrations, or graphs and translates the information into a digital format which a computer can use.
- It transforms an image to the electronic form and divides the image into a grid of boxes.
Chapter 1: Introduction to Personal Computers

Universal Serial Bus (USB):

- USB can be defined as a standard, compact removable storage device that can be connected to any computer, which has a USB port and USB driver.
- Examples are portable flash memory devices, digital cameras, webcams, handheld computers, and optical mice etc.
- The USB device can quickly plug it in and out of a computer without restarting the system.

Other Types of Input Devices

Following are the list of other types of input devices which are majorly used:

- **Joystick**: A lever that moves in all directions and controls the movement of a pointer or some other display symbol; commonly used with computer games.
- **Trackball**: A device that is often used with laptops to move the pointer by rolling it in place.
- **Touch screen**: A type of input devices, which is also a display system that can detect the location of touches within the display area.
Output Devices

Output device can be defined as any computer hardware equipment used to communicate with the user, to display or show the results of data processed.

Monitor
- A monitor can be defined as an output device that enables users to view text and graphical data associated with a computer program.
- It displays the computer programs, text, and cursor movements of the mouse.
- The monitor is the specialized high-resolution screen similar to a television.
- Resolution refers to the sharpness and clarity of images displayed. The thousands of tiny dots on the monitor called pixels determine the clarity of the image.
- The video card installed in computers sends the contents of its video memory to the monitor at a rate of 60 or more times per second.
- The actual display screen is made up of red, green and blue dots that are illuminated by electron beam from behind. The video card DAC chip controls the movement of the electron beam, which then controls what dots are turned on and how bright they are; which then determines the picture you see on the screen.

Fig. 1.1: Monitor

Printers
- A printer is an output device used to transfer a copy of the information that is either stored on your computer or displayed on your screen onto a sheet of paper.
Varieties of printers are available in the market such with special features, such as color and large page formats, such as Laser printers, Inkjet printers, Dot-matrix printers etc.

![HP LaserJet Printers](image)

**Fig. 1.14: HP LaserJet Printers**

**Speakers**

- Speaker is a kind of output device which produce audio output when an audio file is played on computer.

- Speakers are usually equipped with a low-power internal amplifier, which take the electrical signal on a file and translate it back into physical vibrations to create sound waves.

![Speaker](image)

**Fig. 1.15: Speaker**

**Other Peripheral Devices**

- Any external device, which is not necessary to perform the basic operation of computer, is called as peripherals. They provide additional computing capabilities.
Chapter 1: Introduction to Personal Computers

Assam e-District Project

- For ex: External Hard Disk Drives, Modems, Switches, UPS etc.

External Hard Disk Drives (HDD):
- A hard drive that is outside of the computer case in its own enclosure is called an External Hard Drive.
- An external hard drive is connected to the computer system with a single high-speed interface cable, usually with plug-and-play interfaces such as USB or FireWire.
- The capacity of an external HDD measured in GBs/TBs.

Fig. 1.1.6: External Hard Disk Drivers

Switches:
- In networks, a device that filters and forwards packets between LAN segments is called a Switch.
- It is used in a network to connect computers together.
- Switches made for the consumer market are typically small, flat boxes with 4 to 8 Ethernet ports. Example of a switch is HP 3100 SI Switch Series which is attached to your network.

Fig. 1.1.7: 8 Port Switch
Chapter 1: Introduction to Personal Computers

Modem:
- Modulator and Demodulator (UPS) are typically used to send digital data over a phone line.
- The modem at the sending end converts digital data into analog data, which can be transmitted over telephone lines, and the receiving modem converts the analog data back into digital form.
- Modem is used to connect to the Internet.

UPS:
- Uninterruptible Power Supply (UPS), a power supply that includes a battery to maintain power in the event of a power outage.
- A UPS keeps a computer running for several minutes after a power outage, enabling you to save data that is in RAM and shut down the computer gracefully.
- Many UPSs now offer a software component that enables you to automate backup and shut down procedures in case there's a power failure while you're away from the computer.

Fig. 1.18: Line Interactive UPS
Tips for the Maintenance of UPS System

There are preventive as well as corrective steps in the maintenance needs. Preventive involves tips to avoid any sort of issues with the UPS system; while the corrective measures include all the steps undertaken to rectify a problem.

- Connect the right size of the UPS system according to the power supply requirements of the device.
- Do not place the UPS system near any water source or from where water may gain access to the device.
- It is not advised to place the UPS near a source of heat or fire. Do not allow smoke or fire to be in the vicinity of the UPS system or its battery.
- Place it in a well-ventilated spot where there is easy accessibility in case of any issues.
- An ambient temperature of 20-25° C is ideal for the working of the UPS and its battery.
- A clean, dry and dust-free environment is highly recommended for the extended life of the UPS system.
- The UPS system must be kept away from contact with any corrosive materials.
- The output and the input of the UPS system must never be connected.
- The battery discharge and mains failure test has to be carried on at regular intervals for the assessment of its functionality.
- Strike a service contract deal with a reliable provider of UPS maintenance. They will take care of the annual maintenance and repair in case of technical faults.
Summary

- Personal computers are based on the microprocessor technology which works on microchip technology.
- We can use personal computers for word processing, accounting, desktop publishing, and spreadsheet and database management applications.
- Computer is as an electronic device made up of electronic and electro-mechanical components.
- The main computer system contains components like processor, memory, controllers, etc. connected together with a bus (consists of many parallel wires, usually printed (in copper) on the main circuit board (Motherboard) of the computer).
- The main computer system contains components like processor, memory, controllers, etc. connected together with a bus (consists of many parallel wires, usually printed (in copper) on the main circuit board (Motherboard) of the computer).

Exercises

1. What do you understand by Personal Computer?
2. Define the block diagram of Computer.
3. What all are the system components of a personal computer?
4. What do understand by peripheral devices?
5. What do you understand by UPS?
Chapter 2
Introduction to Ubuntu Operating System and Working with Internet

Chapter Objectives:
This chapter provides basic awareness about different operating systems and its architecture. It also provides an overview to the how to work with Ubuntu operating system. It also provides overview to Internet.

Chapter in a Nutshell:
INTRODUCTION TO OPERATING SYSTEMS
INTRODUCTION TO UBUNTU OPERATING SYSTEM
LOGIN SCREEN OF UBUNTU
UNDERSTANDING THE UBUNTU DESKTOP
THE DESKTOP BACKGROUND
THE LAUNCHER
THE DASH
THE WORKSPACES
MANAGING WINDOWS
CLOSING, MAXIMIZING, RESTORING, AND MINIMIZING WINDOWS
MOVING AND RESIZING WINDOWS
SWITCHING BETWEEN OPEN WINDOWS
MOVING A WINDOW TO DIFFERENT WORKSPACE
PLACES
HOME FOLDER
NATUTILUS FILE MANAGER
OPENING FILES
CREATING NEW FOLDERS
COPYING AND MOVING FILES AND FOLDERS
USING MULTIPLE TABS AND MULTIPLE NATUTILUS WINDOWS
SHUT DOWN THE SYSTEM
INTRODUCTION TO NETWORK
INTRODUCTION TO INTERNET
The World Wide Web (WWW)
INTRODUCTION TO EMAIL
EMAIL
NEWS
Read New Email
Send Email
Introduction to Operating Systems

All computers must have an Operating System or OS that runs their programs, manages hardware, recognizes inputs from different sources, and controls the computer’s devices, all without interfering with each other. Without an OS, a computer is nothing but an empty box. It is used as a predefined library for hardware–software interaction. The flowchart below shows the flow of information of a computer, where the operating system is working as an interface between the user, hardware and software:

Fig. 2.1: Flow of information in a computer organization

Development of interactive computation such as time-sharing systems, multiprocessor system, network systems, Distributed systems emerged in the subsequent years and this has been a new step to many new generation operating systems such as Linux, Windows, Ubuntu etc. Following are the few popular operating systems:

Fig. 2.2: Different operating system logos
Introduction to Ubuntu Operating System

Ubuntu was originated in 2004 by Mark Shuttleworth, a South African entrepreneur (and his company Canonical). Ubuntu conceived to address the weakness of Linux and create a system that was easy to use, completely free and could compete with other mainstream operating systems. Ubuntu spread quickly, and its community rapidly grew, and soon Ubuntu became the most popular Linux distribution available.

When you switch on your laptop or the desktop, the Ubuntu will show the login screen. The login screen uses LightDM which is a lightweight on resources and easy to customize display manager. You need to enter your username and the password to get past it. Click your username and enter your password. Once done, you may click the arrow or press Enter to get into the Ubuntu desktop.
Note: Ubuntu supports multiple users and also supports custom backgrounds for each user. During the installation, if the administrator selected automatic login, you may not get the Login Screen. In this case, you will automatically redirected to the desktop application environment of the Ubuntu.

Understanding the Ubuntu Desktop

Ubuntu presents its desktop almost similar to other operating systems such as Microsoft Windows. This is because of the concept of a using graphical user interface (GUI) — to manage the user friendly environment such as showing graphics and usage of mouse to run the applications, move files, and perform most other tasks.

After logging in to Ubuntu, you will see the Unity desktop. It uses Unity as the default desktop environment. This initial view is comprised of the Desktop Background and two bars — one is horizontally located at the top of your desktop and appropriately named the top bar, and the other bar is vertically oriented at the far left, called the Launcher.
The Desktop Background

Below the top bar is an image that covers the entire desktop. This is the default desktop background, or wallpaper, belonging to the default Ubuntu theme is known as Ambiance.

The Top Bar

Fig. 2.6: The Top Bar

The top bar incorporates common functions used in Ubuntu. The right part of the bar is called the indicator area. Each installation of Ubuntu may contain slightly different types and quantities of icons based on a number of factors, including type of hardware and available on-board accessories. The most common indicators are:

<table>
<thead>
<tr>
<th>Indicator Name</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Keyboard indicator</td>
<td>allows you to select the keyboard layout you would like and change your keyboard preferences.</td>
</tr>
<tr>
<td>Messaging indicator</td>
<td>incorporates all your social applications. From here, you can access your instant messenger, your email client, your micro blogging application, and Ubuntu One (an application to use as a personal cloud)</td>
</tr>
<tr>
<td>Network indicator</td>
<td>allows you to manage your network connections and connect quickly and easily to a wired or wireless network.</td>
</tr>
<tr>
<td>Sound indicator</td>
<td>provides an easy way to adjust the sound volume as well as access your music player and sound settings.</td>
</tr>
<tr>
<td>Clock</td>
<td>displays the current time and provides an easy way to access your calendar and Time and Date settings.</td>
</tr>
<tr>
<td>User menu</td>
<td>allows you to easily switch between different users and access your online and user accounts.</td>
</tr>
<tr>
<td>Session indicator</td>
<td>provides an easy way to access System Settings, Updates, Printers, and session options for locking your computer</td>
</tr>
</tbody>
</table>
Chapter 2: Introduction to Ubuntu Operating System and Working with Internet

The Launcher

- The vertical bar of icons on the left side of the screen is called the Launcher.
- The Launcher provides easy access to applications, mounted devices, and the Trash.
- All running applications on your system will place an icon in this Launcher while the application is running.
- The first icon at the top of the Launcher is the Dash (a major innovation and core element of Unity).

Note: By default, other applications appear on the Launcher, including applications such as LibreOffice and Firefox, the Workspace lens, any mounted devices, and Trash lens at the bottom of the Launcher.

Using Launcher Running Applications

- Click on the application's icon from the Launcher.
- Running applications will have one or more triangles on the left side of its icon, indicating the number of application windows open for this application.
- The application in the foreground (meaning on top of all other open application windows) has a white triangle on the right side of its icon.

Note: If you hold the Super (Mouse) key on the Icon, a number will appear on each of the first ten applications, along with a margin containing useful shortcuts. You can launch an application with a number n on it by typing Super+n.

Fig. 2.7: The Launcher in Ubuntu
Below the **Home Folder** icon, you will see the **Firefox** icon. Notice the triangle on the right side indicating it is the application in the foreground (on top of all other applications), and here the triangle on the left side indicating there's only one window associated with Firefox at this time.

**The Dash**

**Dash** is a tool to help you access and find applications and files on your computer quickly.

To explore the Dash:

1. Click on the top-most icon on the Launcher; the icon has the Ubuntu logo on it.
2. After selecting the Dash icon, another window will appear with a search bar on the top as well as grouping of recently accessed applications, files, and downloads.

**Note:** The search bar provides dynamic results as you enter your search terms.

You can also see the Lenses, which act as specialized search categories in the Dash.

The five lenses at the bottom are links to your **Home** lens, **Applications** lens, **Files** lens, and **Music** and **Videos** lenses.

**Search for Files and Applications with the Dash**

Using the **Dash**, you can help you find the names of files or folders.

- Type in what you remember of the name of the file or folder and the Dash will show results it finds as you type.

**Note:** The **Files lens** can also assist you in finding files or folders, which shows you the most recent files accessed, as well as recent downloads.
You can use the filter results button in the top-right corner of the Dash to filter down the results to your requirements by file or folder modification times, by file type (.odt, .pdf, .doc, .tex, etc.), or by size.

- You can use the Application lens on the Dash to automatically categorize installed applications under "Most Frequently Used," "Installed," or "Apps Available for Download."

Note: You can also enter a name of the application or a part of it, and the Dash will return the results. Even if you don’t remember the name of the application at all, type a keyword that is relevant to that application and Dash will find it, in most cases (e.g., type music and Dash will return you the default music player any music player you have used earlier).

Fig. 2.8: Ubuntu Search options

The Workspaces

Workspaces are also known as virtual desktops. These separate views of your desktop allow you to group applications together, and by doing so, help to reduce clutter and improve desktop navigation. In one workspace, you can open all of your media applications; your office suite in another, and your web browser open in a third workspace. Ubuntu has four workspaces by default.
To switch between workspaces:

- Click on the Workspaces Switcher located on the Launcher.

Note: This lens allows you to toggle through the workspaces (whether they contain open applications or not), and choose the one you want to use.

Managing Windows

A window is the box that appears on your screen when you start a program. When opening a program in Ubuntu (such as a web browser or a text editor) a window will appear on your desktop. These windows in Ubuntu are very similar to those in Microsoft Windows. In Ubuntu, the top part of a window (the title bar) will have the title of the window centered (most often, the title will be the name of the application). A window will also have three buttons in the top left corner. From left to right, these buttons represent close, minimize window, and maximize window. Other window management options are available by right-clicking anywhere on the title bar.

Fig. 2.9: An open Window in Ubuntu
In order to perform the close, maximize, restore and minimize the open windows, perform the following actions:

- Click on the in the upper-left corner of the window; the first button on the left hand side.
- The minimize button ( ) which removes the window from the visible screen and places it in the Launcher. Note: This button doesn’t close the application; it just hides the application from view. When an application is minimized to the Launcher, the left-side of the icon in the Launcher will display a triangle showing you the application is still running. Clicking the icon of the application that is minimized will restore the window to its original position.
- The right-most button ( ) is the maximize button, which makes the application window fill the entire screen. Clicking the maximize button again will return the window to its original size.
- If a windows is maximized, its top-left buttons and menu are automatically hidden from view. To make them appear, just move your mouse to the left side of the top bar.
Moving and Resizing Windows

- To move a window around the workspace, place the mouse pointer over the window's title bar, then click and drag the window while continuing to hold down the left mouse button.

- To resize a window, place the pointer on an edge or corner of the window so that the pointer turns into a larger, two-sided arrow, (known as the resize icon). You can then click and drag to resize the window.

Switching Between Open Windows

In Ubuntu there are many ways to switch between open windows.

1. If the window is visible on your screen, you can click any portion of it to raise it above all other windows.
2. Use Alt+Tab to select the window you wish to work with. Hold down the Alt key, and keep pressing Tab until the window you’re looking for appears in the popup.
3. Click on the corresponding icon on the Launcher. Move your mouse to the left side of your screen to show the Launcher, and right-click on the application icon. If the application has multiple windows open, double click on the icon in order to select the window you want.

Moving a Window to Different Workspace

To move a window to a different workspace, make sure the window isn’t maximized. If it is maximized, click on the right-most button on the left side of the title bar to restore it to its original size. Then right-click on the window's title bar and select:

- Move to Workspace Left, to move the window to the left workspace
- Move to Workspace Right, to move the window to the right workspace
• Move to Another Workspace, and then choose the workspace you wish to move the window to.

**Browsing Files on your Computer**

There are two ways to locate files on your computer:

• Search for files
• Access them directly from their folder.

**Note:** You can search for a file via the Dash or Files & Folders in the Launcher. You can also use the Files & Folders tool to access commonly used folders (such as Documents, Music, Downloads), as well as most recently accessed files.

**Places**

To access Places, move your mouse over the top bar and select Places. The Places menu holds a list of commonly used folders (such as Documents, Music, Downloads, and the Home Folder). You can also browse the files on your computer by clicking Computer in this menu. If you set up a home network, you will find a menu item to access shared files or folders. You can also access the Search for Files tool from the Places menu, or browse a list of recently opened folders.
**Home Folder**

The home folder is used to store your personal files. Your home folder matches your login name. When you open your personal folder, you will see there are several more folders inside, including: Desktop (which contains any files that are visible on the desktop), Documents, Downloads, Music, Pictures, Public, Templates, and Videos. These are created automatically the installation process. You can add more files and folders as needed.

**Nautilus File Manager**

- Nautilus file manager is the type of explorer to browse files and folders in your system.
- When you select the Home Folder shortcut in the Launcher or click on a folder in the Dash, or double-click on a folder on the desktop, the Nautilus file manager window opens.
- The default window contains the following features:

| Menu bar | The menu bar is located at the top of the screen.  
|          | These menus allow you to modify the layout of the browser, navigate, bookmark commonly used folders and files, and view hidden folders and files.  
|          | If you bookmark a folder, it will appear in the Bookmarks menu and in the left pane. |

| Toolbar | The toolbar contains tools for navigation as well as resizing the window.  
|         | A drop-down list gives you the option of switching the view from Icon View to List View or Compact View.  
|         | The search icon (which looks like a magnifying glass) opens a field so you can search for a file by name.  
|         | Just below the toolbar, you will see a representation of your current browsing. This is similar to the history function in most browsers; it keeps track of where you are and allows you to backtrack if necessary.  
|         | You can click on the locations to navigate back through the file browser. |
Left page
- The left pane of the file browser has shortcuts to commonly used folders.
- When a folder is bookmarked, it appears in the left pane. No matter what folder is open, the left pane will always contain the same folders.
- This left pane can be changed to display different features (such as Information, Tree, History, etc.) by clicking the down arrow beside Places” near the top.

Central pane
- The largest pane shows the files and folders in the directory that you are currently browsing.
Creating New Folders

To create a new folder from within Nautilus:

- Click File → Create Folder. The folder will appear in your Nautilus manager.
- Name the folder that appears by replacing the default “Untitled Folder” with your desired label (e.g., “Attendance Register”).

Note: You can also create a new folder by pressing Ctrl+Shift+N, or by right-clicking in the file browser window and selecting Create Folder from the popup menu.

Copying and Moving Files and Folders

- You can copy files or folders in Nautilus by clicking Edit → Copy, or by right clicking on the item and selecting Copy from the popup menu.

Note: When using the Edit menu in Nautilus, make sure you’ve selected the file or folder you want to copy first (by left-clicking on it once).

- Multiple files can be selected by left clicking in an empty space (i.e., not on a file or folder), holding the mouse button down, and dragging the cursor across the desired files or folders.

- To select multiple files or folders that are not positioned next to each other, hold down the Ctrl key while clicking on each item individually.

- Once multiple files and/or folders are selected, you can use the Edit menu to perform actions just like you would for a single item.

- When one or more items have been “copied,” navigate to the desired location then click Edit → Paste (or right-click in an empty area of the window and select Paste) to copy
them to the new location. While the copy command can be used to make a duplicate of a file or folder in a new location, the cut command can be used to move files and folders around.

**Note:** You can also use the keyboard shortcuts Ctrl+X, Ctrl+C and Ctrl+V to cut, copy, and paste (respectively) files and folders.

To move a file or folder:

- Select the item you want to move then click **Edit → Cut**.
- Navigate to the desired location, and then click **Edit → Paste**.

**Note:** As with the copy command above, you can also perform this action using the right-click menu, and it will work for multiple files or folders at once. An alternative way to move a file or folder is to click on the item, and then drag it to the new location.

**Using Multiple Tabs and Multiple Nautilus Windows**

Opening multiple Nautilus windows can be useful for dragging files and folders between locations. The option of tabs (as well as panes) is also available in Nautilus.

To open second window when browsing a folder in Nautilus:

- Select **File → New Window** or press **Ctrl+N**. This will open a new window, allowing you to drag files and/or folders between two locations.

To open a new tab:

- Click **File → New Tab** or press **Ctrl+T**. A new row will appear above the space used for browsing your files containing two tabs—both will display the directory you were originally browsing.
To open a second pane:

- Click View → Extra Pane, or press F3 on your keyboard. Again, dragging files and folders between panes is a quick way to move or copy items.

Note: In Nautilus, click Go → Search for Files, or press Ctrl+F and type the keyword to search for files and folders you want to find.

Shut Down the System

Fig. 2.11: Shut down options in Ubuntu

When you have finished working on your computer, you can choose to log out, suspend, restart, or shut down by:

- Click on the Session Indicator on the far right side of the top panel.
- You can also quickly access these options by pressing the Ctrl+Alt+Del keys.
- To reboot your computer, select Shut Down… from the "Session Indicator" and click on Restart.
- To totally power down your computer, select Shut Down… from the "Session Indicator" and click on Shutdown.
**Introduction to Network**

Network is a physical connection of computers from one computer to another, using which one can access to all the resources, including storage, security, printers, and applications. It is similar to having a television that is not connected to cable, where you get basic channels. However, if you connect to a cable operator, there are hundreds of channels providing all kinds of choices you did not have. A network presents the same variety and volume of choices to a computer user.

A network can be considered as a group of two or more computer systems which are connected with each other by special network hardware and software in order to share resources such as files, folders, printers, and applications.

![Computer Network](image)

*Fig. 2.12: Computer Network*

**Introduction to Internet**

- Internet is often can said to be the world’s largest Wide Area Network (WAN).
- It is the network of networks which connects millions of computers all over the world through a system of smaller networks. Anyone in the world can access the Internet.
- To access the Internet, you should connect to a network like an Internet Service Provider (ISP).
- The Internet shares verity of information starting from sending an e-mail to your loved ones to online shopping, finding information and a lot more.
The World Wide Web (WWW)

WWW is a network of servers on the Internet that use specially formatted documents called Web pages. These Web pages are written in a language named Hypertext Markup Language (HTML) that can display text, graphics, animation, and sound.

Browsing the Web

Once you have connected to the Internet, you should be able to browse the web. A web browser is used to connect your system to the internet. Mozilla Firefox is the default application for this in Ubuntu.

Fig. 2:13: Working of Internet

Fig. 2.14: Firefox Browser in Ubuntu
There are several ways to start Firefox. They are:

- Ubuntu has the Firefox icon within the Launcher (the vertical bar down the left side of the screen). Select this icon to open Firefox.
- Open the Dash (the top-most icon in the Launcher) and search for 'firefox' using the search box. If your keyboard has a 'www' button, you can press that button to start Firefox.

When you start Firefox, you will see your home page. By default, this is the Ubuntu Start Page. To quickly go to your home page, press Alt+Home on your keyboard or press on the home icon in Firefox.

To navigate to a new web page, you need to enter its Internet address (also known as a URL) into the Location Bar. URL normally begins with 'http://' followed by one or more names that identify the address.

- One example is 'http://www.google.com/.' (Normally, you can omit the 'http://' part Firefox will fill it in for you.)

![The address bar](image)

- Double-click in the Location Bar, or press Ctrl+L, to highlight the URL that is already there.
- Enter the URL of the page you want to visit. The URL you type replaces any text already in the Location Bar and press Enter.
- If you don't know the URL that you need, type a search term into the Search Bar to the right of the Location bar. Your preferred search engine—Google by default—will return a list of websites for you to choose from.
**Note:** You can also enter your query directly into the Location Bar.  

Most web pages contain links that you can select. These are known as “hyperlinks”. Using the hyperlink you can move to another page, download a document, change the content of the page, and more. To work with hyperlinks:

- Move the mouse pointer until it changes to a pointing finger. This happens whenever the pointer is over a link.

  **Note:** Most links are underlined text, however, buttons and pictures on a web page can also be links. Click the link once. While Firefox locates the link’s page, status messages will appear at the bottom of the window.

- If you want to visit a page you have viewed before, there are several ways to do so. To go back or forward one page, press the **Back** or **Forward** button by the left side of the Location Bar.

- To go back or forward more than one page, click-and-hold on the respective button. You will see a list of pages you have recently visited. To return to a page, select it from the list.

- To see a list of any URLs you have entered into the Location Bar, press the down arrow at the right end of the Location Bar. Choose a page from the list.

- To choose from pages you have visited during the current session, open the History menu and choose from the list in the lower section of the menu.

- To choose from pages you have visited over the past few months, open the **History→Show All History** (or press **Ctrl+Shift+H**). Firefox opens a “Library” window showing a list of folders, the first of which is “**History**.” Select a suitable sub-
folder, or enter a search term in the search bar (at the top right), to find pages you have viewed before. Double-click a result to open the page.

If a page is loading too slowly or you no longer wish to view a page, press Esc to cancel it. To reload the current page if it might have changed since you loaded it, press on the Reload button or press Ctrl+R.

To search the web in Firefox:

- Type a few words into the Firefox search Bar.
- For example, if you want to find information about the Ubuntu: Move your cursor to the Search Bar using your mouse or press Ctrl+K.
- Type the phrase Ubuntu. Your typing replaces any text currently in the Search Bar.
- Press the magnifying glass or Enter to search. Search results from Google for “Ubuntu” will appear in the Firefox window.

**Introduction to eMail**

Email is a communications tool that allows individuals to send, receive, and save messages on their computer. There are different e-mail programs available in the market which helps the users to send and receive mails easily. Each email program is slightly different, but they all do basically the same thing: send and receive mail and attachments. There are two basic variations of email programs:

1. A Web interface (or Internet email), such as Yahoo Mail or Gmail:
   - The email software is a special Web interface on the Web mail server. It requires a separate username and password required to access the email. The mail can be accessed from any computer with Internet access.

2. Client software (or network email), such as Microsoft Outlook or Lotus Notes etc.:
   - The email client software resides on each individual’s network computer. The email server is located in the same network where the individual computers are on. It requires a separate username and password required to access the email.
In some network setup, the username password may not be required. The mail can be accessed from any computer which has the client with Internet access.

**Fig. 2.16: Google Gmail Account**

**E-Mail Views**

The email application screen is divided into different panes so that users can access the mails easily. These include:

- **Preview pane**: Another way of looking at a message. Instead of double-clicking a message to open it, you can read the message appear in the preview pane.
- **Folder pane**: Various folders, including Sent Items, Trash, and Drafts folders, contain messages that you have sent to other individuals, deleted, or messages you started to write but decided to send later.

**Read New Email**

To read email:

1. Locate the Inbox and look for the new mails in the Inbox.
2. Click on the hyperlink of the new mail to open it.

**Send Email**

To create a new mail, click on the **Compose Button** on the e-mail website or New option in any of the e-mail client application. A new page will open as shown in the figure below:
The user needs to provide certain information to send a mail:

1. **Email Addresses**: An email address is made up of three parts, the user name, @ sign and the domain name. For example, an email address "john.joe@gmail.com" contains few elements, such as "john.joe" as the user name, @ is to differentiate the username and the domain name, and "gmail.com" is the e-mail provider’s name. The e-mail ID needs to be added in the To text box provided in the application.

2. **CC text box**: CC means "Carbon Copy". The e-mail address listed in the CC field of a message gets a copy of that the message sent by the user. Other recipients of the e-mail message can see that the e-mail ID you designated as a Cc: received a copy of the message sent.

3. **BCC text box**: BCC means "blind carbon copy." Almost similar to the CC, except that Bcc: recipients are invisible to all the other recipients of the message.

4. **Attachments**: Email programs allow the user to send files as a link with the mails to other recipients. Email program helps the user to add more than one file with a single message as attachments.

5. **Subject**: The user should write a Subject in this text field to signify the summary of the mail which is been sent.

6. **Message filed**: Here, the user will type the message for the recipient.

Once the message is completed, the user can click on the **Send** button to send a message to the recipient. Once the message is sent, it is automatically moved to **Sentmail** folder.
User can view the message by clicking on the **Sentmail** folder listed at the left side of the screen.

**Summary**

- Operating System is used as a predefined library for hardware – software interaction.
- Ubuntu operating system conceived to address the weakness of Linux and create a system that was easy to use, completely free and could compete with other mainstream operating systems. Ubuntu spread quickly.
- You need to login to the Ubuntu in order to work with the operating system.
- Ubuntu’s desktop top bar incorporates common functions used in Ubuntu.
- The Launcher provides easy access to applications, mounted devices, and the Trash.
- **Dash** is a tool to help you access and find applications and files on your computer quickly.
- Workspaces are also known as virtual desktops.
- When opening a program in Ubuntu (such as a web browser or a text editor) a window will appear on your desktop.
- Nautilus file manager is the type of explorer to browse files and folders in your system.
- You can choose to log out, suspend, restart, or shut down through the **Session Indicator** on the far right side of the top panel.
- Internet is often can said to be the world’s largest Wide Area Network (WAN).
- A web browser is used to connect your system to the internet.
- Ubuntu has the Firefox icon within the Launcher (the vertical bar down the left side of the screen).
- Email is a communications tool that allows individuals to send, receive, and save messages on their computer.
Exercise

1. Define Operating System.
2. What do you understand by Ubuntu operating system?
3. How to login to the Ubuntu operating system?
4. Explain how to move a file from one folder to another.
5. What do you understand by e-Mail? Explain how to send an email to your Sr. Officer
Chapter 3: Introduction to LibreOffice Writer

Chapter Objective: LibreOffice Writer is an open-source office productivity tool used for word processing and other office management activities. This chapter gives an in-depth knowledge about the LibreOffice suite and its word processing application called Writer.

Chapter in a Nutshell:
- OVERVIEW OF LIBREOFFICE
- WORKING WITH LIBREOFFICE WRITER
- USING MENUS AND TOOLBARS
- OPENING A DOCUMENT
- SAVING A DOCUMENT
- SAVING AN EXISTING DOCUMENT AT DIFFERENT LOCATION
- Saving Document in Other Formats
- PREVIEWING A DOCUMENT
- FORMATTING TEXT
- FONT AND FONT SIZE
- Applying Font Styles
- APPLYING FONT EFFECTS
- SPELL CHECKING THE TEXT
- FINDING AND REPLACING TEXT
- FORMATTING A DOCUMENT
- SETTING PAGE MARGINS
- SETTING PAGE ORDER
- CREATING AND FORMATTING TABLE
- CREATING A TABLE
- Adding and Merging Rows and Columns
- Merging Cells in a Table
- FORMATTING A TABLE
- CALCULATING DATA OF A TABLE
- SETTING UP HEADERS AND FOOTERS
- INSERTING FIELDS IN A HEADER/FOOTER
- PRINTING A DOCUMENT
Overview of LibreOffice

LibreOffice is a free and open source office suite, developed by The Document Foundation. It was forked from OpenOffice.org in 2010, which was an open-sourced version of the earlier StarOffice. The LibreOffice suite comprises programs to do word processing, spreadsheets, slideshows, diagrams and drawings, maintain databases, and compose math formulae.

Apache LibreOffice consists of the following components:

<table>
<thead>
<tr>
<th><strong>LibreOffice Writer</strong></th>
<th>A word processor with similar functionality and file support to Microsoft Word or WordPerfect. It has extensive WYSIWYG word processing capabilities, but can also be used as a basic text editor.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>LibreOffice Calc</strong></td>
<td>A spreadsheet program, similar to Microsoft Excel or Lotus 1-2-3. It has a number of unique features, including a system which automatically defines series of graphs, based on information available to the user.</td>
</tr>
<tr>
<td><strong>LibreOffice Impress</strong></td>
<td>A presentation program resembling Microsoft PowerPoint. Presentations can be exported as SWF files, allowing them to be viewed on any computer with Adobe Flash installed.</td>
</tr>
<tr>
<td><strong>LibreOffice Draw</strong></td>
<td>A vector graphics editor and diagramming tool. It provides connectors between shapes, which are available in a range of line styles and facilitate building drawings such as flowcharts.</td>
</tr>
<tr>
<td><strong>LibreOffice Math</strong></td>
<td>An application designed for creating and editing mathematical formulae.</td>
</tr>
<tr>
<td><strong>LibreOffice Base</strong></td>
<td>A database management program, similar to Microsoft Access. LibreOffice Base allows the creation and management of databases, preparation of forms and reports that provide end users easy access to data.</td>
</tr>
</tbody>
</table>
### Working with LibreOffice Writer

Writer is a word processing application available in LibreOffice. You can create and edit documents. The following table lists the window elements of Writer:

<table>
<thead>
<tr>
<th>Window Elements</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title bar</td>
<td>Provides the name of application and active document.</td>
</tr>
<tr>
<td>Menu bar</td>
<td>Provides several menus including File, Edit, View, and Insert.</td>
</tr>
<tr>
<td>Standard toolbar</td>
<td>Provides buttons to perform actions, such as opening document, saving document, and closing document.</td>
</tr>
<tr>
<td>Close button</td>
<td>Allows you to close the active document</td>
</tr>
<tr>
<td>Text area</td>
<td>Provides an area to enter and edit text</td>
</tr>
<tr>
<td>Ruler</td>
<td>Provides horizontal and vertical page measurement</td>
</tr>
</tbody>
</table>

Using Menus and Toolbars

Menus and toolbars allow you to select an option with a mouse click. These menus and toolbars are available in the Writer window, as shown in the following figure:

![Diagram of LibreOffice Writer window elements](image)
Menu:
A Menu is a collection of choices, which provides the facilities offered in the application. The Menu bar is available below the Title bar of the window but you can place it anywhere on the screen as it is moveable. Main menus are divided into several submenus. You can click the name of a menu, and then click the menu item that you want to use. The following figure shows the File menu and New submenu in Writer:

Toolbars:
The Standard toolbar resides below the main menu. It provides quick access to frequently used commands, such as open, print, export to PDF, Cut, Copy, Paste etc.

Opening a Document
LibreOffice Writer is capable of opening and saving documents in various formats, including Microsoft Word’s DOC, RTF, XHTML, and the OASIS Open Document Format. For example, if you want to create a letter in Writer, then you can to open a blank document.
To open a new document, perform the following steps:

Note: Click New shortcut button on the Standard toolbar to open a new document.

To open an existing document, perform the following steps:

1. Click File → Open to display the Open dialog box, as shown in the following figure:

   ![Open Dialog Box](image)

   Fig. 3.4: The Open Dialog Box

   Notes: To open a file you can use the Open shortcut button on the Standard toolbar.

2. Select the location from where you want to open a document.

3. Select the file and click the Open button to open the document.

   Notes: You can also open an existing document by specifying the absolute path of a file in the File name text box.
To enter text in a new document, perform the following steps:

1. Place the cursor on the Text area.
2. Enter text, such as TOM and JERRY and press the ENTER key to end a paragraph or a line.

Saving a Document

After you have entered some text, you can save the document. Writer provides the facility to save your document. To save a document, perform the following steps:

1. Click File  Save As display Save As dialog box, as shown in the following figure:

```
Fig. 3. 5: The Save As Dialog Box
```

2. Select the drive or folder from the Save in list box where you want to save the document. For example, E:\Library\Tools

3. Enter file name in the File name text box. For example, Office Tools.

4. Click the Save button to save the file.
After any change or modification in old or existing document, you can save it by clicking the Save button from Standard toolbar or by pressing the CTRL+S shortcut key.

Saving an Existing Document at Different Location

1. Select File → Save As to display Save As dialog box.
2. Choose Location, such as E:\Library\Tools where you want to save your file.
3. Click the Save button.

Saving Document in Other Formats

1. Click the File menu and select the SaveAs option to display the Save As dialog box.
2. Choose Location, such as E:\Library\Tools where you want to save your file.
3. Type the name, such as Document for the file in the File name text box.
4. Select a file format, such as .html in the Save As type list box.
5. Click the Save button to save the file.

Notes: If you want to set another file format as default to save the files, click on the Tools → Options → Load/Save → General, menu option to open Options - Load/Save - General dialog and select the desired file format in document type under default file format.
Chapter 3: Introduction to LibreOffice Writer

Previewing a Document
LibreOffice Writer page preview option enables you to view how a document will look when printed. For example, if you want to print a document which is of fifty pages then you can modify the header, footer, alignment and other formatting factors by previewing the document. Writer provides various previewing options in the Preview toolbar, as shown in the following figure:

Fig. 3.6: Page Preview Toolbar Options

To preview a document, perform the following steps:

1. Select File  Page Preview to open the Page Preview window.
2. From the Zoom toolbar, you can select the desired zoom percentage.
3. Click the Full Screen button to see the document on full screen.
4. Click the Multiple Pages button to see several pages at the same time.
5. Click the Close Preview button to close the Page Preview window.

Notes: You can also select File  Page Preview to preview a document before printing.

Formatting Text
To make your document readable and presentable, LibreOffice Writer provides a variety of font colors, sizes and styles. It also enables you to search a specific word in the whole document and replace the word with another word. You can also check and correct spellings of the words in Writer.
Font and Font Size

A font can be defined as a digital representation of text that includes different characteristics such as typeface, point size, weight, or design. Using different font sizes, you can make your document more readable.

Applying Font Styles

A font is a named set of characters, such as letters, numbers, punctuation marks, and so on, that combines several design qualities. Font is actually a writing style of text with different design qualities.

Notes:
The default font size of Writer is 12 pt. The size is measured in points, sometimes abbreviated as pt or pts. 1 point = 1/72 inch.

To change font and font size, perform the following steps:

1. Select the text in the document by pressing the Shift + Right Arrow keys.
2. Select Format  Character… to open the Character dialog box, as shown in the following figure:

![Character Dialog Box](image)

The same font will be used as with your printer and your screen.

document readable and presentable. Apache OpenOffice writer provides a way...
3. Select the Arial font style from the Font list.
4. Select Regular from the Typeface list.
5. The different available typefaces are:

- Regular Exp: Simplexity
- Italic Exp: Simplexity
- Bold Exp: Simplexity
- Bold Italic Exp: Simplexity
- Underline Exp: Simplexity

6. Select the available font size, for example 12 from the Size list to apply in the document.
7. Click the OK button to apply the font formatting in the document.

**Applying Font Effects**

LibreOffice Writer allows you to apply various font effects, such as Underline, Strikethrough, and Font color. Adding color to your text is another effective method for making text stand out. By coloring, you can point out significant information to the reader.

To apply font effects, perform the following steps:

1. Select the text in the document where you want to apply font effect.
2. Select Format→Character option to open the Character dialog box.
3. Click the Font Effects tab to open the Font Effects tab page, as shown in the following figure:
To make your **document readable and presentable** writer provides...
Chapter 3: Introduction to LibreOffice Writer

To check spelling automatically, perform the following steps:

1. Click the Tools ➔ Spelling and Grammar menu option to display Spelling dialog box, as shown in the following figure:

   Fig. 3: The Spelling Dialog Box

   ![Spelling and Grammar dialog box](image)

2. The Spellchecker automatically adds the underlined word and the replaced word to the AutoCorrect list for the current language.

Finding and Replacing Text

LibreOffice Writer enables to search specific text in the document. It can also replace a text with the other text. It minimizes the search time and effort to find and replace a text within the document.

For example, you created a document about current marketing strategy you adopted for your company and submitted to your senior for approval. Your senior wants to change or replace some word in this document according to his/her requirement. This can be done manually or by using the Find and Replace feature of Writer. Manual replacing may not be accurate and require time to search and replace each occurrence.
To use Find & Replace, perform the following steps:

1. Select Edit → Find & Replace to display the Find & Replace dialog box, as shown in the following figure:

   ![Find & Replace dialog box](image)

2. Enter the word you want to search in the Search for list box. For example, Windows.

3. Enter the word you want to replace in Replace with list box. For example, Linux.

4. Click Find All button to search the specified word in the whole document.

5. Click the Replace All command button for replacement of the word in the whole document.

6. Click the Close button to close the dialog box.

Notes: Press CTRL+H to display Find & Replace dialog box. You can also use CTRL+F to display the Find option at the bottom of the screen in order to find the matched text in the document.
Formatting a Document

In some cases, when you create a document, the typed text may not fit on the page. LibreOffice Writer provides a variety of options to set the alignment, margins, and orientation of text in a document.

Setting Page Margins

Distance between page boundary and text is known as a page margin. For example, if you print some text on an office letter head without checking and adjusting the page margins. How you notice that the text has printed over the letter head text? How will you resolve this problem?

LibreOffice Writer solves this problem by setting the page margins. It provides four basic types of page margins, which are: Top, Bottom, Right, and Left. In this topic, you will learn how to set the page margins.

Setting margins enable you to specify how much white space should display for the top, bottom, left, and right areas on each printed page. To change a page margin, perform the following steps:

1. Click the **Format**→**Page** menu option to display **Page Style: Default** dialog box. In this dialog box various tabs are available, for example: Organizer, Page, Background, Header, Footer, Borders, Columns, Footnote, as shown on the following figure:
Fig. 1.1: Organizer Tab on Page Style: Default dialog box

Select Page tab to apply the Paper format and Margins, as shown on the following figure:

Fig. 1.2: Page Tab on Page Style: Default dialog box

3. Select the following formatting option available in Paper format section:
   a. Select the A3 option from the Format list box.
   b. Enter 11.69 cm in the Width text box.
   c. Enter 16.54 cm in the Height text box.
Chapter 3: Introduction to LibreOffice Writer

Select the Portrait radio button to set the page Orientation.

Enter 1.01 cm in the Left, 0.79 cm in the Right, 1.01 cm in the Top, and 0.79 cm in the Bottom text boxes under the Margins section, as shown on the following figure:

![Fig. 3. Page Tab on Page Style: Default dialog box](image)

Click the OK button to apply the page margins.

Setting Page Border

With the help of page border, you can make your document look more attractive.

LibreOffice Writer provides the option for page formatting by using the page border. To apply page border, perform the following steps:

1. Click the Format → Page menu option to display Page Style: Default dialog box, as shown in the following figure:
Creating and Formatting Table

You can represent tabular data, consisting of rows and columns, using tables. To create and format a table, you need to perform the following tasks:

- Create a new table.
- Enter data in a table.
- Format a table.
- Make calculations on the data of a table.

Creating a Table

A table is a group of rows and columns. It consists of boxes, called cells. A cell is basically an intersection of rows and columns. A group of cells arranged vertically is called a column, and a group of cells arranged horizontally is called a row.
For example, you have to present monthly selling figures of a book publication company. There are two ways to present data, one is to present in the text format and the other is to present the data in the tabular form. Consider that the monthly book selling of Amazon Company are:

- The selling of book no. 901 is 200 in January, 300 in February, and 400 in March.
- The selling of book no. 905 is 800 in January, 900 in February, and 950 in March.
- The selling of book no 909 is 600 in January, 700 in February, and 750 in March.

By analyzing this table you can conclude that the production in March is better than the other months. However, if we create a table as shown below, it makes it clear to the reader to understand the facts much better and beautiful way. The following table shows the same data in a table format:

<table>
<thead>
<tr>
<th>Book No.</th>
<th>January</th>
<th>February</th>
<th>March</th>
</tr>
</thead>
<tbody>
<tr>
<td>901</td>
<td>200</td>
<td>300</td>
<td>400</td>
</tr>
<tr>
<td>905</td>
<td>800</td>
<td>900</td>
<td>950</td>
</tr>
<tr>
<td>909</td>
<td>600</td>
<td>700</td>
<td>750</td>
</tr>
</tbody>
</table>

Table is the format provided by LibreOffice to manage data in a meaningful way. To create a new table, perform the following steps:

1. Click **Table→Insert→Table** menu option to display the **Insert Table** dialog box, as shown in the following figure:
Fig. 3.15: The Insert Table Dialog Box

2. Type 4 in the Columns text box and 3 in the Rows text box under the Size section.

3. Select the Border check box to apply border in the table.

4. Click the OK button to create a table.

Adding and Merging Rows and Columns

In a table, rows and columns can be increased or decreased based on your requirement. For accommodating more data, you have to add more rows in the existing table. For example, in a table you have provided information only for 3 months but the information will gradually increase for 6 months, in that case, you can increase the number of rows in a table.

To add rows in a table, perform the following steps:

1. Click the Table ➤ Insert ➤ Rows menu option to display Insert Rows dialog box, as shown in the following figure:
Chapter 3: Introduction to LibreOffice Writer

Fig. 3.16: Insert Rows Dialog Box

1. Enter the number of rows, such as 4, that you want to add in the Amount text box.
2. Select the After radio button under the Position section to specify that you want to add rows after the existing rows in a table.
3. Click the OK button to add rows.

To insert columns in a table, perform the following steps:

1. Select the Table ➞ Insert ➞ Columns menu option to display Insert Column dialog box, as shown in the following figure:

Fig. 3.17: Insert Columns Dialog Box

2. Enter the number of columns, such as 4, in the Amount text box.
3. Select the Before radio button under the Position section to specify that you want to add columns before the existing columns in a table.
4. Click the OK button to add columns.
Merging Cells in a Table

It can select adjacent cells and then merge into a single cell. To merge cells in a table, select adjacent cells of the table and then from the Table menu, select the Merge Cells option to merge the cells.

Formatting a Table

You can format a table using the Table toolbar. It enables you to format the background, table border, and border style. You can use a variety of fonts, font style, effects, borders, and shading options over your table to present it in an effective manner. Writer provides pre-formatted table designs, which you can apply directly to create a designer table.

To apply the preformatted styles in a table, perform the following steps:

1. Click the Table  AutoFormat menu option to display the AutoFormat dialog box, as shown in the following figure:

   ![AutoFormat Dialog Box](image)

2. Select a formatting style, such as Brown from the Format list and the preview is displayed.

3. Click the Add button to add user defined table format in the Format list.

4. Click the OK button to apply the auto format style in a table.

![AutoFormat Dialog Box](image)
Calculating Data of a Table

After entering and formatting data in the table, you can perform mathematical calculations on the numeric data available in the table. For example, you are creating daily sales sheet by entering daily sales in a column but after completion of the month, you want to get total sales for the month. Writer provides this facility to calculate the data.

To insert calculation directly into a text table, perform the following steps:

1. Select the table and click on Table → Formula or press F2. The formula bar will appear below the standard toolbar as shown below:

   ![Formula bar](image)

   **Fig. 3.1**: Formula bar

2. Type '=' and click on the Formula button and select Sum from the drop down list, as shown below:

   ![Formula drop down list](image)

   **Fig. 3.2**: Functions

3. Select range of cells with numeric values on which you want to perform the calculation. Selection will automatically add the addresses of the cells in the formula bar.
Setting up Headers and Footers

By using headers and footers, you can add titles, dates, and page numbers or any other information in your document, and it will appear on each page of your document automatically. So the common information which we want to specify on each page can be put through headers and footers. Generally, headers are used to display company names, phone numbers, and addresses. Whereas, footers are used to display page numbers, company names, and titles. In this topic, you learn how to use headers and footers.

A header is the blank area at the top margin of any page and footer is the blank area at the bottom margin. Headers and footers can contain textual or graphical information to provide context for the reader. Any page that uses the same style, automatically receives the header or footer that you add. You can insert Fields, such as page number and chapter heading, in a text document. In Writer, you can add default header and footer or can also customize it.

To add default headers and footers in a document, perform the following steps:

1. Click the Insert → Header → Default menu option, to insert header on the document and automatically place the cursor on the header. Specify the text that you want to display on header.
2. To add footer, click the Insert → Footer → Default menu option, and automatically place the cursor on the footer. Specify the text, such as ©Copyright that you want to display on footer.

Inserting Fields in a Header / Footer

Writer enables you to insert various fields, such as date, time, page number, and page count, in a document. This information improves the text quality of your document. You can also insert reference in your document. The advantage of entering a cross-reference as a field is that you do not have to adjust the references manually every time you change the document.
If you want to provide information, such as date, time, page number, or title information on your document, then you need to insert fields in your document which contain information that can be automatically updated.

To insert a field, perform the following steps:

1. Click the Insert → Header → Default menu option, to insert header on the document.
2. Click the Insert → Field menu option, select desired field such as Date, Time, Page Number, and Page Count, you want to insert.

Fig. 3.21: Inserting Field to a LibreOffice Writer header

One can insert header and footer from the Page Style: Default dialog box by performing the following steps:

1. Click the Format → Page menu option to display the Page Style: Default dialog box.
Fig. 3.2: Page Style: Default dialog box

2. Click the Header tab to add header in your document.
3. Select the Header on check box to enable the header.
4. Select the Autofit height check box to automatically adjust with the page.
5. Click the Footer tab to add footer in your document.
6. Select the Footer on check box to enable the header.
7. Click the Insert  Field  Page Number menu option to insert the page number.
8. Select the Autofit height check box to automatically adjust with the page.

Printing a Document

You can print the document if you are satisfied with its appearance. To print a document, select File  Print to open the Print dialog box. Then click the OK button to print the document, as shown in the following figure.
Chapter 3: Introduction to LibreOffice Writer

Summary

- The LibreOffice suite comprises programs to do word processing, spreadsheets, slideshows, diagrams and drawings, maintain databases, and compose math formulae.
- LibreOffice Writer is capable of opening and saving documents in various formats, including Microsoft Word's DOC, RTF, XHTML, and the OASIS Open Document Format.
- Menus and toolbars allow you to select an option with a mouse click.
- You can click File → Save As to save the file in to your system.
- LibreOffice Writer page preview option enables you to view how a document will look in when printed.
- Writer provides a variety of font colors, sizes and styles.
- LibreOffice Writer allows you to apply various font effects, such as Underline, Strikethrough, and Font color.

Fig. 3.23: Print Dialog Box

Notes:
To print a document you can also select File → Print menu option or press CTRL+P shortcut key.
LibreOffice Writer enables to write spelling-error free document by using the **Spell Checker** facility which will automatically checks and informs you about misspells with a red wavy line.

LibreOffice Writer enables to search specific text in the document and replace a text with the other text.

A table is a group of rows and columns. It consists of boxes, called cells. A cell is basically an intersection of rows and columns.

A header is the blank area at the top margin of any page and footer is the blank area at the bottom margin.

**Exercises**

1. What do you understand by Word Processing applications and how does LibreOffice Writer came introduced?
2. Explain how to open a document in LibreOffice Writer.
3. What is the use of previewing a document before printing? Explain the process of preview the document.
4. What is Table in LibreOffice Writer. Explain how to insert a table in your document.
5. Explain how to insert Header/Footer in your document.
Chapter Objective:

LibreOffice Calc is a component of the LibreOffice spreadsheet software package. Calc is similar to any other spreadsheet applications like Microsoft Excel etc. This chapter gives an in-depth knowledge about the LibreOffice Calc working environment and functions.

Chapter in a Nutshell:

OVERVIEW OF LIBREOFFICE CALC

GETTING STARTED WITH LIBREOFFICE CALC

SAVE A FILE

OPENING A FILE

FORMATTING TEXT AND NUMBERS

SELECTING CELLS

FORMATTING CELLS

USING TABLE AUTOFORMAT

COPYING AND PASTING CELLS

TEXT SUPERSCRIPT AND TEXT SUBSCRIPT

ROTATING TEXT

TEXT ALIGNMENT

CONDITIONAL FORMATTING

NAMING CELLS

ROUNDING OFF NUMBERS

FORMATTING NUMBERS

ENTERING FRACTIONS

FORMATTING SPREADSHEETS

Formatting Cell Border and Background

ADDING, DELETING, AND RENAMING SHEETS OF A SPREADSHEET

CREATING AND MODIFYING CHARTS

ANALYZING DATA

AUTOFILTER Advanced Filters

MANAGING ROWS AND COLUMNS

INSERTING ROWS AND COLUMNS

FORMATTING ROWS AND COLUMNS

FORMULAS AND CALCULATIONS

CALCULATING USING FORMULAS

CALCULATING THE SERIES AUTOMATICALLY
Overview of LibreOffice Calc

LibreOffice Calc is used to create and manage spreadsheets. It enables you to perform calculations, view reports, create and modify charts, manage rows and columns, edit and format text, analyze, and share data.

Getting Started with LibreOffice Calc

To create a file in LibreOffice Calc, perform the following steps:

1. To start the spreadsheet application, click on the Dash home, type LibreOffice Calc and select LibreOffice Calc window, as shown in the following figure.

2. Click File  New  Spreadsheet menu option to open a new Calc spreadsheet. You can also press the CTRL + N shortcut key to open a new Calc spreadsheet.

3. Click the desired cell where you want to enter data and start typing.
Save a File

Calc provides the facility to save your created file for future use. To save a file for the first time, perform the following steps:

1. To open the Save As dialog box, click on File → Save As option, as shown in the following figure:

   ![Save As Dialog Box](image)

2. Select the location where you want to save your file by selecting a folder from the list.

3. Type the name of the file, such as My Spreadsheet in the File name text box.

4. Click the Save button to save the file.

Note: After changing or modifying an old or exiting spreadsheet, you can save the modifications by clicking the Save button, or pressing short-cut key Ctrl+S.
To save an existing file at a different location, perform the following steps:

1. Open an existing file.
2. Click **File ➔ Save As** to display the **Save As** dialog box.
3. Choose the location where you want to save your file from the list.
4. Type a different name in the **File name** box, if you want to create or save another copy of the same document at the same location.
5. Click the **Save** button to create or save another copy of the same file at desired location.

**Saving a File in Other Formats**

To save a file in other formats, perform the following steps:

- Click **File ➔ Save As** to display the **Save As** dialog box.
- Select the location, such as `E:\LibreOffice` where you want to save your file.
- Type the name for the file, such as **My Spreadsheet** in the **File name** text box.
- Select the desired file format from the **Save as type** list box.
- Click on the **Save** button to save the file with the defined name and format.

**Notes:** You can export your spreadsheet in different format by clicking **File ➔ Export** to display the **Export** dialog box and selecting the options according to your requirement.

**Opening a File**

To open a file, such as **Document** that you created in LibreOffice Calc, perform the following steps:

1. Click **File ➔ Open** menu option, to display the **Open** dialog box, as shown in the following figure:
Fig. 4.3: The Open Dialog Box

2. Select the location, such as E:\LibreOffice, where you saved the file from the Look in the list.
3. Click on the Open button to open the desired file.

Formatting Text and Numbers
LibreOffice Calc allows you to implement various formatting styles on text and numbers as per your requirement. Using these formatting styles, the document becomes more feasible and presentable. The various formatting styles in LibreOffice Calc are:

- Selecting cells
- Copying/Pasting cells
- Text Superscript/Subscript
- Rotating Text
- Text Alignment
- Conditional Formatting
- Naming Cells
Chapter 4: Introduction to LibreOffice Calc

- Formatting Spreadsheets
- Formatting Numbers as Text
- Entering Fractions
- Choosing themes for Sheets
- Using Rounded-Off Numbers

Selecting Cells

You need to select the cell or range of cells, if you want to perform any operation on data. To select the cell or cells in a spreadsheet, perform the following steps:

1. Click the cell that you want to select, and similarly in case of range of cells, you need to press and hold down the left mouse button and drag the mouse. After selecting the cells, you can release the left mouse button.

Note: You can also click the desired cell and hold down the SHIFT key and start moving towards the desired direction using the arrow keys. The cell selection is shown in the following figure:

Fig. 4.4: Selecting Cells

Formatting Cells

Formatting Cells function allows you to make changes to the cells, such as changing the font style, giving effects to the fonts, alignment of the text in a cell, and giving borders and background.
To change the format of the cell, perform the following steps:

1. Select the cells to format.
2. Open the Format Cells dialog box by selecting Format  Cells or press Ctrl+1.
3. Click the Font tab to display the Font tab page as shown in the following figure:

   ![Fig. 4.5: The Font Tab Page](image)

4. Make the changes according to your requirement and click the OK button to accept the new style.

Using Table AutoFormat

The AutoFormat function allows you to change the format of a selected range of cells. To auto format the tables:

1. Select the cells containing text along with the row and column headers to format.
2. Click Format  AutoFormat menu option to display the AutoFormat page, as shown in the following figure:
3. Select the Brown option and click the OK button to display the brown color in the selected cells.

Note: Click View → Value Highlighting to view the change in color of cell contents.

Copying and Pasting Cells

You can copy and paste the cells, which contain the information according to your requirement. For example, your manager instructed you to send the sales figures for the month of November, but you have figures for the whole year in your spreadsheet. To handle such situation, you can copy and paste the sales figures for the month of November on a different spreadsheet to send the required sheet with required information to the manager.

To copy a cell or cell range, perform the following steps:

1. Select the desired cell or cell range using mouse or keyboard.
2. Right-click the selected cell to display a shortcut menu. Select the Copy option to copy the cell or content of the cell.

Note: You can also click File → Copy, or click on the copy icon from Standard toolbar, or press CTRL+C shortcut keys to copy the selected cell.
To paste a cell or cell range, you need to:

1. Select the cell where you want to paste the copied data of cell(s).
2. Right-click the target cell to display a shortcut menu. Select the Paste option to paste the copied cell.

Note: You can also click File → Paste, or click on the Paste icon from the Standard toolbar, or press CTRL+V shortcut keys to paste the copied cell.

Fig. 4.7: Copying and pasting Cells

Text Superscript and Text Subscript

Text Superscript and Text Subscript style allow your text to appear as a Superscript or Subscript. For this, you need to perform the following steps:

1. Select the character that you want to denote as subscript or superscript.
2. Click Format → Character to display the Character dialog box, as shown in the following figure:
Chapter 4: Introduction to LibreOffice Calc

3. Click the Font Position tab and select the Subscript or Superscript option under the Position section, according to your requirement.

4. Click on the OK button to accept the settings. The selected portion of the text will appear as Subscript or Superscript.

Rotating Text

Rotating Text feature enables you to format the text within a cell. You can align your text to any direction; left, right, center, top, or bottom, and can even rotate the text to different angles.

To rotate the text in any direction, perform the following steps:

1. Select the cells containing the text that you want to rotate.

2. Click Format ➔ Cells menu option to display the Format Cells dialog box, as shown in the following Fig.:
Chapter 4: Introduction to LibreOffice Calc

Select the Alignment tab, which contains a Text alignment and Text orientation area as shown in the following figure:

Fig. 4.9: The Format Cells Dialog Box

Fig. 4.10: Alignment Tab – Format Cells Dialog Box
4. Select the direction in which you want to rotate the text in the Text orientation area.

5. Click the OK button to apply the settings.

Text Alignment

Text alignment allows you to align the text of your document. To change the alignment of the text, perform the following steps:

1. Select the cells in which you want the text to align.

2. Open the Format cells dialog box and select the Alignment tab.

3. Select the desired option to align text horizontally or vertically in the Text alignment area, as shown in the following figure:

4. Click the OK button to accept the settings.

![Format Cells dialog box](image)
Conditional Formatting

Formatting is an option that allows you to edit the styles of text, numbers, and pages based on conditions. The formatting will take effect only if the contents in the cells satisfy those conditions. There is no need to check the conditions manually and make the changes.

To apply conditional formatting, perform the following steps:

1. Select Format → Conditional Formatting menu option to display the Conditional Formatting dialog box, as shown in the following figure:

   ![Conditional Formatting Dialog Box](image)

   You are allowed to define conditions cell-by-cell or in sequential order for the cells to have particular formatting.

   For example, while calculating the average, you can highlight the totals that exceed the average value of all the totals. In case the total changes, the format also changes accordingly, so there is no need to make the changes manually.

   You can also add more conditions to your formatting by clicking on the Add button.

Naming Cells

Naming cells allow you to name each and every cell or a range of cells for your easy identification. To name a cell, perform the following steps:
Chapter 4: Introduction to LibreOffice Calc

1. Select a cell or range of cells to which you want to assign a name.
2. Click Insert → Names → Define menu option to display the Define Names dialog box.
3. Type a name, such as Marks in the Name field.
4. Click the Add button to add the LibreOffice Calc name in the Name field, as shown in the following figure:

   ![Define Name Dialog Box](image)

   Fig. 4.1: The Define Names Dialog Box

5. Click the OK button to accept the settings.

Note: Similarly, when you type the name in a formula, you will find the entire name as a tip. Press ENTER to accept the name from the tip. If more than one name starts with the same character, scroll through all the names using the TAB key.

Rounding Off Numbers

The decimal numbers are rounded off to two decimal places, by default in LibreOffice Calc.

To change the default setting, perform the following steps:

1. Select the cells you want to modify.
2. Open the Numbers tabbed page in the Format Cells dialog box.
3. Select the Number option from the Category list.
4. Select the number of decimal places from the Decimal places list.
5. Click the OK button to accept the settings.
Formatting Numbers

You can denote the numbers entered in a cell as text with this formatting option. For example, you want to change 500 to 500.00 formats then you can use this formatting option.

To format the numbers, perform the following steps:

1. Open the Format Cells dialog box.
2. Select the Numbers tab to display the Numbers tabbed page.
3. Select the Number option from the Category list and select the -1234.12 in Format list.
4. Click the OK button to accept the settings.
**Entering Fractions**

To work with fractions for your calculations, **Calc** allows you to convert a number into a fraction. To enter a fraction, perform the following steps:

1. Type a value, such as 0 1/2 in a cell and press the **Enter** key.
2. The **AutoCorrect** setting causes the three characters 1, / and 2 to be changed as 0 ½
3. To enter multi-digit fractions, such as 28.5686478, open the **Numbers** tabbed page in the **Format Cells** dialog box.
4. Select the **Fraction** option from the **Category** list. Click the **OK** button to display the value that you entered in fractions, as 28 4/7.

**Formatting Spreadsheets**

**LibreOfficeCalc** allows you to format text, numbers, borders, and backgrounds for cells and pages in a spreadsheet.

You can format your text as per your requirement, such as changing the font of the text from **Times New Roman** to **Arial** or changing the font size from **12** to **14**. To format a text in a spreadsheet, perform the following steps:

1. Select the text that you want to format.
2. Select **Format → Cells...** option to open the **Format Cells** dialog box.
3. Click the **Font** tab and select the text attributes according to your requirement to format your text as shown in the following figure:
Click the OK button to accept the settings.

Formatting Cell Border and Background

You can change the appearance of the cell by formatting its borders and background. To format the border and background of the cell, perform the following steps:

1. Select a range of cells that you want to format.
2. Open the Format Cells dialog box.
3. Click the Borders or Background tab to display the required tabbed page.
4. Select the attributes according to your requirement, such as shadows and backgrounds, as shown in the following figure:

Fig. 4.1: The Borders Tab – Format Cells

5. Click the OK button to accept the settings for formatting the selected cells.

6. You can also add background to the selected cell by selecting the Background tab from the Format Cells dialog box as shown below:

Fig. 4.1: The Background Tab – Format Cells
Adding, Deleting, and Renaming Sheets of a Spreadsheet

You want to create a spreadsheet to show sales figures of your company on one sheet and purchase figures on another sheet, but Calc provides only one sheet, by default. You can insert or add a new sheet in your existing spreadsheet. Calc provides the facility to keep them all together in one saved file, and to move between them.

To add or insert a new sheet, perform the following steps:

1. Click Insert ➔ Sheet menu option to display the Insert Sheet dialog box, as shown in the following figure:

   ![Insert Sheet Dialog Box](image)

   *Fig. 4.18: The Insert Sheet Dialog Box*

2. Select the options, such as After current sheet and From a file according to your requirement under the Position and Sheet sections.

3. Click the OK button to accept the settings.

Note: You can select From file option under the Sheet section to link a sheet from another external spreadsheet.
To delete a sheet, perform the following steps:

1. Click Edit → Sheet → Delete menu option to display LibreOffice 4.3.0.4 message box, as shown in the following figure:

Fig. 4.19: The LibreOffice 4.3.0.4 Message Box

2. Click the Yes button to delete the sheet permanently.

To rename a sheet, perform the following steps:

1. Right-click on the sheet name at the bottom of the window and select Rename Sheet option to display the Rename Sheet dialog box, as shown in the following figure:

Fig. 4.20: The Rename Sheet Dialog Box

2. Specify a name, such as document in the Name text box.

3. Click the OK button to rename the sheet.
Creating and Modifying Charts

Charts are enabled in LibreOffice Calc to create and view block diagrams, create spreadsheets using block diagrams, and graphs, to define the growth of an organization. To create and modify a chart, perform the following steps:

1. Open the LibreOffice Calc window with data range.
2. Select inside the cell range that you want to present in your chart.
3. Click Insert → Object → Chart menu option to display the Chart Wizard page, as shown in the following figure:

   ![Chart Wizard - Chart Type Page](image)

4. Select Column from Chart Type: and click Next button to display the Data Range page, as shown in the following figure:
Click the Next button to display the Data Series page, as shown in the following figure.

Click the Next button to display the Data Elements page for choosing titles, legend, and grid settings.

Type Subjects in the Title box, as shown in the following figure.
Chapter 4: Introduction to LibreOffice Calc

Fig. 4.2: Chart Wizard - Data Elements Page

Click the Finish button to display the chart on Calc sheet, as shown in the following figure:

Fig. 4.2: Calc Spreadsheet Column Chart

Analyzing Data

Data Analyzing is a process of arranging an item list in a logical order of ascending or descending order of data. Following are list of data analysis method in Calc:

- AutoFilter
- Advanced Filters
- Sort Lists
**AutoFilter**

AutoFilter feature allows you to restrict the display of identical records quickly. To enable AutoFilter, perform the following steps:

1. Select the column that you want to filter.
2. Click **Data ➔ Filter ➔ AutoFilter** to display a drop-down arrow in the selected column.
3. Click the drop-down arrow to display a shortcut menu, which contains options, such as **All** and **Top 10**.
4. Select an option according to your requirement and run the filter. Now, only the contents that meet the criteria are visible.

**Advanced Filters**

Advanced filter allows up to eight conditions to be applied for filter. To apply advanced filter to a record, perform the following steps:

1. Create a table containing the following data in LibreOffice Calc:

<table>
<thead>
<tr>
<th>Name</th>
<th>Marks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shawn</td>
<td>67</td>
</tr>
<tr>
<td>Shawn</td>
<td>45</td>
</tr>
<tr>
<td>Harish</td>
<td>34</td>
</tr>
<tr>
<td>Harish</td>
<td>45</td>
</tr>
<tr>
<td>Tom</td>
<td>90</td>
</tr>
</tbody>
</table>

2. Select the table and click **Data ➔ Filter ➔ Standard Filter** menu option to display the **Standard Filter** page as shown in the following figure:
3. Select the Name option from the first Field name list. Select = from the first Condition list and select Harish from the first Value list.

4. Select AND option from the first Operator list. Select the Marks option from the second Field name list and select < from the second Condition list. Select 56 from the second Value list.

5. Click the OK button to get the result. The result displayed is Harish 34 and Harish 45.

6. Click Data ➔ Filter ➔ Advanced Filter menu option to open the Advanced Filter page, as shown in the following figure:

7. Specify the sheet number in the second textbox, such as $A$B$, and click the button to get the specific result. The result consists of only those rows whose cell value matches the filtering criteria.
Managing Rows and Columns

LibreOffice Calc employs functions, such as, applying styles, inserting new rows and columns, deleting and editing rows and columns, and auto formatting tables to manage rows and columns in a table.

Inserting Rows and Columns

To insert a row or a column in an existing table, perform the following steps:

1. Select the cell where you want to insert a row or a column.
2. Click **Insert ➔ Rows** to insert a row. To insert a column, select **Insert ➔ Columns** to insert a column.

   Note: You can also press the keys **ALT+I** to open the **Insert** menu and select **Rows or Columns** option.

Formatting Rows and Columns

Calc allows you to change the height or width of a row or a column. To change the height or width of a row or a column, perform the following steps:

1. Click **Format ➔ Row ➔ Height** menu option to display the **Row Height** dialog box, as shown in the following figure:

   ![Row Height dialog box](image)

   *Fig.4.27: The Row Height dialog box*

2. Select the height, such as **1.6** or **0.7**, of the column from the **Height** list.
3. Click the **OK** button to accept the changes.
4. Click \textbf{Format} $\rightarrow$ \textbf{Column} $\rightarrow$ \textbf{Width} menu option to display the \textbf{Column Width} page, as shown in the following figure:

\begin{figure}[h]
\centering
\includegraphics[width=0.5\textwidth]{column_width.png}
\caption{The Column Width dialog box}
\end{figure}

5. Select the width, such as \textbf{0.78} or \textbf{1.4} of the column from the \textbf{Width} list.
6. Click the \textbf{OK} button to accept the changes.

\section*{Formulas and Calculations}

\textbf{LibreOfficeCalc} allows you to write formulas and perform complex calculations. Various types of calculations you can perform in Calc are:

\begin{enumerate}
  \item Calculations using Formulas
  \item Automatically Calculating the Series
\end{enumerate}

\section*{Calculating using Formulas}

A formula consists of arithmetic signs, such as +, -, *, /, logical operators, and functions. They may also contain text and other formatting details. Generally formula begins with equal sign. You can perform calculations using formulas in \textbf{Calc}.

For example: The formula $= (B2*B3)$ displays the product of the contents of the cell B2 and B3. The following Fig. shows the result of the previous calculation:
Calculating the series automatically allows you to list the contents automatically with natural number series instead of manually filling the cells. To fill the cells with a series, perform the following steps:

1. Click a cell and type a number, such as 1, and press ENTER key.
2. Select the cell in which you entered a number in the preceding step.
3. Move the mouse pointer to the lower right edge of the cell. The mouse pointer changes to a + sign, as shown in the following figure:

   ![Auto Fill Mouse Pointer](image)

4. Press the left mouse button and drag the mouse pointer down wards. After dragging up to five cells, release the mouse to fill the cells with sequentially values.
Summary

- LibreOffice Calc is used to create and manage spreadsheets. It enables you to perform calculations, view reports, create and modify charts, manage rows and columns, edit and format text, analyze, and share data.
- **LibreOffice Calc** allows you to implement various formatting styles on text and numbers as per your requirement.
- Formatting Cells function allows you to make changes to the cells, such as changing the font style, giving effects to the fonts, alignment of the text in a cell, and giving borders and background.
- The AutoFormat function allows you to change the format of a selected range of cells. To auto format the tables:
- You can copy and paste the cells, which contains the information according to your requirement.
- Text Superscript and Text Subscript style allow your text to appear as a Superscript or Subscript.
- Rotating Text feature enables you to format the text within a cell.
- Conditional formatting is an option that allows you to edit the styles of text, numbers, and pages based on conditions.
- The decimal numbers are rounded off to two decimal places, by default in LibreOffice Calc.
- To work with fractions for your calculations, **Calc** allows you to convert a number into a fraction.
- **LibreOffice Calc** allows you to format text, numbers, borders, and backgrounds for cells and pages in a spreadsheet.
- Charts are enabled in **Calc** to create and view block diagrams, create spreadsheets using block diagrams, and graphs, to define the growth of an organization.
Exercises

1. What do you understand by Spreadsheet and LibreOffice Calc?
2. Explain how to format text and numbers in LibreOffice Calc.
3. What is conditional formatting? Explain how to perform the conditional formatting for a series of data.
4. Explain how to format the sheet and take print out of the spreadsheet.
5. What is Chart in LibreOffice Calc? Explain how to incorporate a chart in your LibreOffice Calc spreadsheet.
Notes